Comcast Nation Wide Outage
Incident Report for Crosswind Cloud Solutions
Resolved
No longer seeing new reports of Comcast problems. We will continue to monitor and reopen this issue if it becomes a problem again.
Posted Nov 09, 2021 - 11:34 MST
Update
Outage seems to be mostly cleared for most Comcast customers. We will continue to monitor.
Posted Nov 09, 2021 - 10:46 MST
Update
Comcast seems to be returning to normal. We are currently seeing less then 1% of our customers impacted currently.
Posted Nov 09, 2021 - 08:29 MST
Monitoring
Comcast is currently having a nation wide outage. This outage will affect your voice and data services. If you have a backup internet you should not see an impact with any of your Crosswind services.

https://blockclubchicago.org/2021/11/09/comcast-internet-down-across-chicago
Posted Nov 09, 2021 - 07:34 MST