Carrier Experiencing an Unknown Issue
Incident Report for Crosswind Cloud Solutions
Resolved
Carrier has identified the issue and a fix is in progress will update once more is known or calls return to normal.
Posted Dec 19, 2016 - 21:22 MST
Update
Carrier has identified the issue and a fix is in progress will update once more is known or calls return to normal.
Posted Dec 19, 2016 - 20:56 MST
Identified
We have identified that a carrier of our is experiencing and unknown issue that is effected some inbound DID numbers. We are working on a resolution now. We will update once we know more.
Posted Dec 19, 2016 - 19:54 MST