ULC Under DDOS Attack
Incident Report for Crosswind Cloud Solutions
Resolved
There have been no further issues with this ULC is over 48 hours. We feel this problem to be under control.
Posted Mar 05, 2016 - 14:46 MST
Update
The affected ULC remains stable at this time no further issues have affected their ability to deliver us PSTN traffic. We continue to monitor the attack, and work with their network team.
Posted Mar 04, 2016 - 07:21 MST
Update
The ULC is still getting attacked and doing their best to mitigate the attack. We at Crosswind are in the process of migrating those numbers effected away from this ULC. As this process will take some time we continue to monitor the situation.
Posted Mar 03, 2016 - 09:18 MST
Update
We have seen no further issues from the effected ULC and believe the problem to be under control. We will close this out in the morning if there are no further issue tonight.
Posted Mar 02, 2016 - 21:11 MST
Update
Network has been stable have not had any additional issues at this time. We have been told that the FBI and other Law enforcement have been brought into the mix, as-well as additional resources that specialize in DDOS mitigation.
Posted Mar 02, 2016 - 14:19 MST
Update
We are continuing to work with our ULC on the DDOS issue. They have implemented some additional hardware to help prevent the attack traffic from reaching the core of their network. It has been 9 hours since we have seen any impact on traffic from their network. We along with other providers such as ourselves have been engaged with them and will continue to do so until we are confident this issue has cleared. We will also be working with our other carriers today to take some additional step to mitigate this. I also thought I would take some time and explain just what a DDOS attack is as we have gotten a few questions as to just what is going on. A DDOS or distributed denial of service attack, basically means that an attacker is pushing so much garbage traffic at your network (in this case gigabits per second) that the network gear has trouble keeping up. To mitigate such an attack you have to develop what are called attack signature and configure your core routers to dump that traffic and or ignore traffic matching those signatures immediately. However as is the nature with such a targeted attack-the attacker can change tactics, as we have seen with this attack, requiring you to configure new attack signatures. It’s during this reconfiguration process that connectivity issue can happen as the core routers are trained to filter out the new attack signatures. The impact that we have seen from attack has impacted less than 1% of all calls to or from our customers in the past 24 hours.
Posted Mar 02, 2016 - 07:44 MST
Monitoring
For the past 24 hours, our primary carrier, ULC, has been under a targeted DDOS attack effecting their PSTN, API and web services. This has had an impact to all of their customer, including our customers throughout the country. The attack is coming in at the rate of Gigabits per second. While services have not gone down, there has been some traffic that is not getting through the network from time to time. At times, this is taking 15-20 minutes and is effecting inbound traffic only. Our team has been working with the ULC all day and will continue to work with them through the night. Traffic is currently flowing normally through our network as of 7PM PT. We are actively working to help mitigate the attack from impacting our customers.
Posted Mar 01, 2016 - 21:43 MST